TIBCO Security Advisory: December 17, 2019 - TIBCO Spotfire - 2019-17334

TIBCO Spotfire Analyst and Desktop Remote Code Execution Via Shared Files

Original release date: December 17, 2019
Last revised:
CVE-2019-17334
Source: TIBCO Software Inc.

Systems Affected

  • TIBCO Spotfire Analyst versions 7.11.1 and below
  • TIBCO Spotfire Analyst versions 7.12.0, 7.13.0, 7.14.0, 10.0.0, 10.1.0, 10.2.0, 10.3.0, 10.3.1, and 10.3.2
  • TIBCO Spotfire Analyst versions 10.4.0, 10.5.0, and 10.6.0
  • TIBCO Spotfire Analytics Platform for AWS Marketplace version 10.6.0
  • TIBCO Spotfire Deployment Kit versions 7.11.1 and below
  • TIBCO Spotfire Desktop versions 7.11.1 and below
  • TIBCO Spotfire Desktop versions 7.12.0, 7.13.0, 7.14.0, 10.0.0, 10.1.0, 10.2.0, 10.3.0, 10.3.1, and 10.3.2
  • TIBCO Spotfire Desktop versions 10.4.0, 10.5.0, and 10.6.0
  • TIBCO Spotfire Desktop Language Packs versions 7.11.1 and below

The following component is affected:

  • Visualizations

Description

The component listed above contains a vulnerability that theoretically allows an attacker with permission to write DXP files to the Spotfire library to remotely execute code of their choice on the user account of other users who access the affected system. This attack is a risk only when the attacker has write access to a network file system shared with the affected system.

Impact

The impact of this vulnerability includes the theoretical possibility that the attacker gains full control of the user account that accesses affected system.

  CVSS v3 Base Score: 7.6 (CVSS:3.0/AV:A/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H)

Solution

TIBCO has released updated versions of the affected systems which address this issue:

  • TIBCO Spotfire Analyst versions 7.11.1 and below update to version 7.11.2 or higher
  • TIBCO Spotfire Analyst versions 7.12.0, 7.13.0, 7.14.0, 10.0.0, 10.1.0, 10.2.0, 10.3.0, 10.3.1, and 10.3.2 update to version 10.3.3 or higher
  • TIBCO Spotfire Analyst versions 10.4.0, 10.5.0, and 10.6.0 update to version 10.6.1 or higher
  • TIBCO Spotfire Analytics Platform for AWS Marketplace version 10.6.0 update to version 10.6.1 or higher
  • TIBCO Spotfire Deployment Kit versions 7.11.1 and below update to version 7.11.2 or higher
  • TIBCO Spotfire Desktop versions 7.11.1 and below update to version 7.11.2 or higher
  • TIBCO Spotfire Desktop versions 7.12.0, 7.13.0, 7.14.0, 10.0.0, 10.1.0, 10.2.0, 10.3.0, 10.3.1, and 10.3.2 update to version 10.3.3 or higher
  • TIBCO Spotfire Desktop versions 10.4.0, 10.5.0, and 10.6.0 update to version 10.6.1 or higher
  • TIBCO Spotfire Desktop Language Packs versions 7.11.1 and below update to version 7.11.2 or higher

The information on this page is being provided to you on an "AS IS" and "AS-AVAILABLE" basis. The issues described on this page may or may not impact your system(s). TIBCO makes no representations, warranties, or guarantees as to the information contained herein. ANY AND ALL WARRANTIES, EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION, INCLUDING, BUT NOT LIMITED TO, IMPLIED WARRANTIES OF MERCHANTABILITY, NON-INFRINGEMENT AND FITNESS FOR A PARTICULAR PURPOSE ARE HEREBY DISCLAIMED. BY ACCESSING THIS DOCUMENT YOU ACKNOWLEDGE THAT TIBCO SHALL IN NO EVENT BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, PUNITIVE, OR CONSEQUENTIAL DAMAGES THAT ARISE OUT OF YOUR USE OR FAILURE TO USE THE INFORMATION CONTAINED HEREIN. The information on this page is being provided to you under the terms of your license and/or services agreement with TIBCO, and may be used only for the purposes contemplated by the agreement. If you do not have such an agreement with TIBCO, this information is provided under the TIBCO.com Terms of Use, and may be used only for the purposes contemplated by such Terms of Use.

SECURITY ADVISORIES FOR TIBCO PRODUCTS

ADVISORY FREQUENTLY ASKED QUESTIONS

Security FAQs