TIBCO Security Advisory: June 26, 2018 - TIBCO Spotfire - 2018-5437

Frequently Asked Questions

General FAQ

Why is this advisory being issued?

Security vulnerabilities have been discovered in:

  • TIBCO Spotfire® Analyst versions 7.8.0 and below
  • TIBCO Spotfire® Analyst versions 7.9.0 and 7.9.1
  • TIBCO Spotfire® Analyst versions 7.10.0 and 7.10.1
  • TIBCO Spotfire® Analyst version 7.11.0
  • TIBCO Spotfire® Analyst version 7.12.0
  • TIBCO Spotfire® Analytics Platform for AWS Marketplace versions 7.12.0 and below
  • TIBCO Spotfire® Automation Services versions 7.12.0 and below
  • TIBCO Spotfire® Deployment Kit versions 7.8.0 and below
  • TIBCO Spotfire® Deployment Kit versions 7.9.0 and 7.9.1
  • TIBCO Spotfire® Deployment Kit versions 7.10.0 and 7.10.1
  • TIBCO Spotfire® Deployment Kit version 7.11.0
  • TIBCO Spotfire® Deployment Kit version 7.12.0
  • TIBCO Spotfire® Desktop versions 7.8.0 and below
  • TIBCO Spotfire® Desktop versions 7.9.0 and 7.9.1
  • TIBCO Spotfire® Desktop versions 7.10.0 and 7.10.1
  • TIBCO Spotfire® Desktop version 7.11.0
  • TIBCO Spotfire® Desktop version 7.12.0
  • TIBCO Spotfire® Desktop Language Packs versions 7.8.0 and below
  • TIBCO Spotfire® Desktop Language Packs versions 7.9.0 and 7.9.1
  • TIBCO Spotfire® Desktop Language Packs versions 7.10.0 and 7.10.1
  • TIBCO Spotfire® Desktop Language Packs version 7.11.0

What is the impact of these vulnerabilities?

For detailed information on the vulnerability, please see the security advisory.

Which customers are affected?

These issues affect all customers using the above product versions.

Where can I get software updates?

Customers with current maintenance for the affected products can obtain product updates through their standard TIBCO fulfillment channel, via the Community site, or via the AWS Marketplace as appropriate.

How will customers who receive TIBCO software via OEM partners be affected?

Customers of OEM partners can receive new versions and hot fixes from their OEM partners. Please contact your OEM partner for updates.

Can I get the software update if I am not current on maintenance, if I do not have access to the download site or access to TIBCO Support?

Please contact us through this online form, and we will get in touch with you. Please reference CASE ID: 01600168 in your communication to indicate the context of your request.

What is TIBCO doing to prevent future security issues?

TIBCO takes security very seriously. We perform rigorous testing for every product release, as well as code audits, structured walkthroughs and peer reviews. TIBCO has identified security vulnerabilities in products during internal testing and reviews and corrected them prior to release. TIBCO constantly evaluates and augments its security measures and will continue to do so.

Where can I get more information?

Product advisories can be accessed from the Security Advisories for TIBCO Products web page.

Customers with a current maintenance contract with TIBCO can log a case with TIBCO Global Support (please refer to the service request identifier listed above) and then call your support telephone number. Maintenance customers can also view product-specific Late Breaking News through the TIBCO Support Web.

TIBCO Spotfire® Analyst

Which product versions are affected?

  • TIBCO Spotfire® Analyst versions 7.8.0 and below
  • TIBCO Spotfire® Analyst versions 7.9.0 and 7.9.1
  • TIBCO Spotfire® Analyst versions 7.10.0 and 7.10.1
  • TIBCO Spotfire® Analyst version 7.11.0
  • TIBCO Spotfire® Analyst version 7.12.0

Which components are affected?

  • TIBCO Spotfire® Client
  • TIBCO Spotfire® Web Player Client

How should customers handle these issues?

For each affected system, customers should update to:

  • TIBCO Spotfire® Analyst versions 7.8.0 and below update to version 7.8.1 or higher
  • TIBCO Spotfire® Analyst versions 7.9.0 and 7.9.1 update to version 7.9.2 or higher
  • TIBCO Spotfire® Analyst versions 7.10.0 and 7.10.1 update to version 7.10.2 or higher
  • TIBCO Spotfire® Analyst version 7.11.0 update to version 7.11.1
  • TIBCO Spotfire® Analyst version 7.12.0 update to version 7.13.0

Please follow the instructions in the product installation manual.

What is updated by this new product version?

Please see the readme, release notes and/or documentation for a complete list of changes.

Which TIBCO products include TIBCO Spotfire® Analyst?

Products that include TIBCO Spotfire® Analyst:

  • TIBCO® Analytics

TIBCO Spotfire® Analytics Platform for AWS Marketplace

Which product versions are affected?

  • TIBCO Spotfire® Analytics Platform for AWS Marketplace versions 7.12.0 and below

Which components are affected?

  • TIBCO Spotfire® Client
  • TIBCO Spotfire® Web Player Client

How should customers handle these issues?

For each affected system, customers should update to:

  • TIBCO Spotfire® Analytics Platform for AWS Marketplace versions 7.12.0 and below update to version 7.13.0 or higher

Please follow the instructions in the product installation manual.

What is updated by this new product version?

Please see the readme, release notes and/or documentation for a complete list of changes.

TIBCO Spotfire® Automation Services

Which product versions are affected?

  • TIBCO Spotfire® Automation Services versions 7.12.0 and below

Which components are affected?

  • TIBCO Spotfire® Client
  • TIBCO Spotfire® Web Player Client

How should customers handle these issues?

For each affected system, customers should update to:

  • TIBCO Spotfire® Automation Services versions 7.12.0 and below update to version 7.13.0 or higher

Please follow the instructions in the product installation manual.

What is updated by this new product version?

Please see the readme, release notes and/or documentation for a complete list of changes.

Which TIBCO products include TIBCO Spotfire® Automation Services?

Products that include TIBCO Spotfire® Automation Services:

  • TIBCO® Analytics
  • TIBCO® Analytics - Business Author Add-on
  • TIBCO® Analytics - Consumer Add-on

TIBCO Spotfire® Deployment Kit

Which product versions are affected?

  • TIBCO Spotfire® Deployment Kit versions 7.8.0 and below
  • TIBCO Spotfire® Deployment Kit versions 7.9.0 and 7.9.1
  • TIBCO Spotfire® Deployment Kit versions 7.10.0 and 7.10.1
  • TIBCO Spotfire® Deployment Kit version 7.11.0
  • TIBCO Spotfire® Deployment Kit version 7.12.0

Which components are affected?

  • TIBCO Spotfire® Client
  • TIBCO Spotfire® Web Player Client

How should customers handle these issues?

For each affected system, customers should update to:

  • TIBCO Spotfire® Deployment Kit versions 7.8.0 and below update to version 7.8.1 or higher
  • TIBCO Spotfire® Deployment Kit versions 7.9.0 and 7.9.1 update to version 7.9.2 or higher
  • TIBCO Spotfire® Deployment Kit versions 7.10.0 and 7.10.1 update to version 7.10.2 or higher
  • TIBCO Spotfire® Deployment Kit version 7.11.0 update to version 7.11.1 or higher
  • TIBCO Spotfire® Deployment Kit version 7.12.0 update to version 7.13.0 or higher

Please follow the instructions in the product installation manual.

What is updated by this new product version?

Please see the readme, release notes and/or documentation for a complete list of changes.

Which TIBCO products include TIBCO Spotfire® Deployment Kit?

Products that include TIBCO Spotfire® Deployment Kit:

  • TIBCO Spotfire® Server

TIBCO Spotfire® Desktop

Which product versions are affected?

  • TIBCO Spotfire® Desktop versions 7.8.0 and below
  • TIBCO Spotfire® Desktop versions 7.9.0 and 7.9.1
  • TIBCO Spotfire® Desktop versions 7.10.0 and 7.10.1
  • TIBCO Spotfire® Desktop version 7.11.0
  • TIBCO Spotfire® Desktop version 7.12.0

Which components are affected?

  • TIBCO Spotfire® Client
  • TIBCO Spotfire® Web Player Client

How should customers handle these issues?

For each affected system, customers should update to:

  • TIBCO Spotfire® Desktop versions 7.8.0 and below update to version 7.8.1 or higher
  • TIBCO Spotfire® Desktop versions 7.9.0 and 7.9.1 update to version 7.9.2 or higher
  • TIBCO Spotfire® Desktop versions 7.10.0 and 7.10.1 update to version 7.10.2 or higher
  • TIBCO Spotfire® Desktop version 7.11.0 update to version 7.11.1 or higher
  • TIBCO Spotfire® Desktop version 7.12.0 update to version 7.13.0 or higher

Please follow the instructions in the product installation manual.

What is updated by this new product version?

Please see the readme, release notes and/or documentation for a complete list of changes.

TIBCO Spotfire® Desktop Language Packs

Which product versions are affected?

  • TIBCO Spotfire® Desktop Language Packs versions 7.8.0 and below
  • TIBCO Spotfire® Desktop Language Packs versions 7.9.0 and 7.9.1
  • TIBCO Spotfire® Desktop Language Packs versions 7.10.0 and 7.10.1
  • TIBCO Spotfire® Desktop Language Packs version 7.11.0

Which components are affected?

  • TIBCO Spotfire® Client
  • TIBCO Spotfire® Web Player Client

How should customers handle these issues?

For each affected system, customers should update to:

  • TIBCO Spotfire® Desktop Language Packs versions 7.8.0 and below update to version 7.8.1 or higher
  • TIBCO Spotfire® Desktop Language Packs versions 7.9.0 and 7.9.1 update to version 7.9.2 or higher
  • TIBCO Spotfire® Desktop Language Packs versions 7.10.0 and 7.10.1 update to version 7.10.2 or higher
  • TIBCO Spotfire® Desktop Language Packs version 7.11.0 update to version 7.11.1 or higher

Please follow the instructions in the product installation manual.

What is updated by this new product version?

Please see the readme, release notes and/or documentation for a complete list of changes.

Which TIBCO products include TIBCO Spotfire® Desktop Language Packs?

Products that include TIBCO Spotfire® Desktop Language Packs:

  • TIBCO Spotfire® Desktop

---------------------