TIBCO Security Advisory: July 21, 2015 - TIBCO Spotfire® Web Player

Frequently Asked Questions

General FAQ

Why is this advisory being issued?

Security vulnerabilities have been discovered in:

  • TIBCO Spotfire® Analyst 5.5.1 and earlier, 6.0.0, 6.0.1, 6.0.2, 6.5.0, 6.5.1, 6.5.2 and 7.0.0
  • TIBCO Spotfire® Analytics Platform for AWS Marketplace 6.5 and 7.0.0

  • TIBCO Spotfire® Automation Services 5.5.1 and earlier, 6.0.0, 6.0.1, 6.0.2, 6.5.0, 6.5.1, 6.5.2 and 7.0.0
  • TIBCO Spotfire® Deployment Kit 5.5.1 and earlier, 6.0.0, 6.0.1, 6.0.2, 6.5.0, 6.5.1, 6.5.2 and 7.0.0
  • TIBCO Spotfire® Desktop 6.5.1 and earlier and 7.0.0
  • TIBCO Spotfire® Desktop Language Packs 7.0.0
  • TIBCO Spotfire® Professional 5.5.1 and earlier, 6.0.0, 6.0.1, 6.0.2, 6.5.0, 6.5.1, 6.5.2 and 7.0.0
  • TIBCO Spotfire® Web Player 5.5.1 and earlier, 6.0.0, 6.0.1, 6.0.2, 6.5.0, 6.5.1, 6.5.2 and 7.0.0
  • TIBCO Silver® Fabric Enabler for Spotfire® Web Player 2.1.0 and earlier
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  

What is the impact of these vulnerabilities?

For detailed information on the vulnerability, please see the security advisory.

Which customers are affected?

These issues affect all customers using the above product versions.

Where can I get software updates?

Customers with current maintenance can obtain product updates through their standard TIBCO fulfillment channel.

How will customers who receive TIBCO software via OEM partners be affected?

Customers of OEM partners can receive new versions and hot fixes from their OEM partners. Please contact your OEM partner for updates.

Can I get the software update if I am not current on maintenance, if I do not have access to the download site or access to TIBCO Support?

Please contact TIBCO Support by telephone. Please reference SR_ID: 600589 in your communication to indicate the context of your request.

I use a TIBCO hosted version of an affected product - is this version vulnerable?

TIBCO updates all hosted versions simultaneously with the announcement of a vulnerability.

What is TIBCO doing to prevent future security issues?

TIBCO takes security very seriously. We perform rigorous testing for every product release, as well as code audits, structured walkthroughs and peer reviews. TIBCO has identified security vulnerabilities in products during internal testing and reviews and corrected them prior to release. TIBCO constantly evaluates and augments its security measures and will continue to do so.

Where can I get more information?

Product advisories can be accessed from the Security Advisories for TIBCO Products web page.

Customers with a current maintenance contract with TIBCO can log a service request with TIBCO Global Support (please refer to the service request identifier listed above) and then call your support telephone number. Maintenance customers can also view product-specific Late Breaking News through the TIBCO Support Web.

TIBCO Spotfire Analyst

Which product versions are affected?

  • TIBCO Spotfire Analyst 5.5.1 and earlier, 6.0.0, 6.0.1, 6.0.2, 6.5.0, 6.5.1, 6.5.2 and 7.0.0

Which components are affected?

  • TIBCO Spotfire Professional
  • TIBCO Spotfire Deployment Kit

How should customers handle these issues?

For each affected system, customers should update to:

  • TIBCO Spotfire Analyst 5.5.x version 5.5.2 or higher
  • TIBCO Spotfire Analyst 6.0.X version 6.0.3 or higher
  • TIBCO Spotfire Analyst 6.5.X version 6.5.3 or higher
  • TIBCO Spotfire Analyst 7.0.X version 7.0.1 or higher

or the equivalent, publicly-accessible hotfixes available from the standard Support channels.

Please follow the instructions in the product installation manual.

What is updated by this new product version?

Please see the readme, release notes and/or documentation for a complete list of changes.

TIBCO Spotfire Analytic Platform for AWS Marketplace

Which product versions are affected?

  • TIBCO Spotfire Analytic Platform for AWS Marketplace 6.5 and 7.0.0

Which components are affected?

  • TIBCO Spotfire Deployment Kit

How should customers handle these issues?

For each affected system, customers should update to:

  • TIBCO Spotfire Analytic Platform for AWS Marketplace 7.0.1 or higher

or the equivalent, publicly-accessible hotfix available from the standard Support channels.

Please follow the instructions in the product installation manual.

What is updated by this new product version?

Please see the readme, release notes and/or documentation for a complete list of changes.

TIBCO Spotfire Automation Services

Which product versions are affected?

  • TIBCO Spotfire® Automation Services 5.5.1 and earlier, 6.0.0, 6.0.1, 6.0.2, 6.5.0, 6.5.1, 6.5.2 and 7.0.0

Which components are affected?

  • TIBCO Spotfire client

How should customers handle these issues?

For each affected system, customers should update to:

  • TIBCO Spotfire Automation Services 5.5.X version 5.5.2 or higher
  • TIBCO Spotfire Automation Services 6.0.X version 6.0.3 or higher
  • TIBCO Spotfire Automation Services 6.5.X version 6.5.3 or higher
  • TIBCO Spotfire Automation Services 7.0.X version 7.0.1 or higher

or the equivalent, publicly-accessible hotfixes available from the standard Support channels.

Please follow the instructions in the product installation manual.

What is updated by this new product version?

Please see the readme, release notes and/or documentation for a complete list of changes.

Which TIBCO products include TIBCO Spotfire Automation Services?

Products that include TIBCO Spotfire Automation Services include:

  • TIBCO Cloud Analytics

TIBCO Spotfire Deployment Kit

Which product versions are affected?

  • TIBCO Spotfire® Deployment Kit 5.5.1 and earlier, 6.0.0, 6.0.1, 6.0.2, 6.5.0, 6.5.1, 6.5.2 and 7.0.0

Which components are affected?

  • TIBCO Spotfire client

How should customers handle these issues?

For each affected system, customers should update to:

  • TIBCO Spotfire Deployment Kit 5.5.X version 5.5.2 or higher
  • TIBCO Spotfire Deployment Kit 6.0.X version 6.0.3 or higher
  • TIBCO Spotfire Deployment Kit 6.5.X version 6.5.3 or higher
  • TIBCO Spotfire Deployment Kit 7.0.X version 7.0.1 or higher

or the equivalent, publicly-accessible hotfixes available from the standard Support channels.

Please follow the instructions in the product installation manual.

What is updated by this new product version?

Please see the readme, release notes and/or documentation for a complete list of changes.

Which TIBCO products include TIBCO Spotfire Deployment Kit?

Products that include TIBCO Spotfire Deployment Kit include:

  • TIBCO Spotfire Server
  • TIBCO Cloud Analytics
  • TIBCO DataSynapse Analytics
  • TIBCO LogLogic Visual Analytics

TIBCO Spotfire Desktop

Which product versions are affected?

  • TIBCO Spotfire® Desktop 6.5.1 and earlier and 7.0.0

Which components are affected?

  • TIBCO Spotfire client

How should customers handle these issues?

For each affected system, customers should update to:

  • TIBCO Spotfire Desktop 6.5.X version 6.5.2 or higher
  • TIBCO Spotfire Desktop 7.0.X version 7.0.1 or higher

or the equivalent, publicly-accessible hotfixes available from the standard Support channels.

Please follow the instructions in the product installation manual.

What is updated by this new product version?

Please see the readme, release notes and/or documentation for a complete list of changes.

TIBCO Spotfire Desktop Language Packs

Which product versions are affected?

  • TIBCO Spotfire® Desktop Language Packs 7.0.0

Which components are affected?

  • TIBCO Spotfire client

How should customers handle these issues?

For each affected system, customers should update to:

  • TIBCO Spotfire Desktop Language Packs 7.0.X version 7.0.1 or higher

or the equivalent, publicly-accessible hotfixes available from the standard Support channels.

Please follow the instructions in the product installation manual.

What is updated by this new product version?

Please see the readme, release notes and/or documentation for a complete list of changes.

Which TIBCO products include TIBCO Spotfire Desktop Language Packs?

Products that include TIBCO Spotfire Automation Services include:

  • TIBCO Spotfire Desktop

TIBCO Spotfire Professional

Which product versions are affected?

  • TIBCO Spotfire® Professional 5.5.1 and earlier, 6.0.0, 6.0.1, 6.0.2, 6.5.0, 6.5.1, 6.5.2 and 7.0.0

Which components are affected?

  • TIBCO Spotfire client

How should customers handle these issues?

For each affected system, customers should update to:

  • TIBCO Spotfire Professional 5.5.X version 5.5.2 or higher
  • TIBCO Spotfire Professional 6.0.X version 6.0.3 or higher
  • TIBCO Spotfire Professional 6.5.X version 6.5.3 or higher
  • TIBCO Spotfire Professional 7.0.X version 7.0.1 or higher

or the equivalent, publicly-accessible hotfixes available from the standard Support channels.

Please follow the instructions in the product installation manual.

What is updated by this new product version?

Please see the readme, release notes and/or documentation for a complete list of changes.

Which TIBCO products include TIBCO Spotfire Professional?

Products that include TIBCO Spotfire Professional include:

  • TIBCO Spotfire Analyst
  • TIBCO Cloud Analytics
  • TIBCO DataSynapse Analytics
  • TIBCO LogLogic Visual Analytics

TIBCO Spotfire Web Player

Which product versions are affected?

  • TIBCO Spotfire Web Player 5.5.1 and earlier, 6.0.0, 6.0.1, 6.0.2, 6.5.0, 6.5.1, 6.5.2 and 7.0.0

Which components are affected?

  • TIBCO Spotfire Web Player client

How should customers handle these issues?

For each affected system, customers should update to:

  • TIBCO Spotfire Web Player 5.5.x version 5.5.2 or higher
  • TIBCO Spotfire Web Player 6.0.X version 6.0.3 or higher
  • TIBCO Spotfire Web Player 6.5.X version 6.5.3 or higher
  • TIBCO Spotfire Web Player 7.0.X version 7.0.1 or higher

or the equivalent, publicly-accessible hotfixes available from the standard Support channels.

Please follow the instructions in the product installation manual.

What is updated by this new product version?

Please see the readme, release notes and/or documentation for a complete list of changes.

Which TIBCO products include TIBCO Spotfire Web Player?

Products that include TIBCO Spotfire Web Player include:

  • TIBCO Spotfire® Server
  • TIBCO® Cloud Analytics
  • TIBCO DataSynapse™ Analytics
  • TIBCO LogLogic® Visual Analytics

TIBCO Silver® Fabric Enabler for Spotfire Web Player

Which product versions are affected?

  • TIBCO Silver Fabric Enabler for Spotfire Web Player 1.6.0, 1.6.1 and 2.1.0

Which components are affected?

  • TIBCO Spotfire Web Player client

How should customers handle these issues?

For each affected system, customers should update to:

  • TIBCO Silver Fabric Enabler for Spotfire Web Player version 2.1.1 or higher

Please follow the instructions in the product installation manual.

What is updated by this new product version?

Please see the readme, release notes and/or documentation for a complete list of changes.

Which TIBCO products include TIBCO Silver Fabric Enabler for Spotfire Web Player?

Products that include TIBCO Silver Fabric Enabler for Spotfire Web Player include:

  • TIBCO Silver® Fabric Manager

---------------------